How to install ruby 1.9.3 on ubuntu

how to install ruby 1.9.3 on ubuntu

Subscribe to RSS

sudo apt-get install ruby cd /etc/alternatives sudo ln -sf /usr/bin/ruby ruby. May 02,  · sudo apt-get update sudo apt-get install ruby rubydev \ rubygems irb ri rdoc \ build-essential libopenssl-ruby libssl-dev zlib1g-dev sudo update-alternatives --install /usr/bin/ruby ruby /usr/bin/ruby \--slave /usr/share/man/man1/rubygz rubygz \ /usr/share/man/man1/rubygz \--slave /usr/bin/ri ri /usr/bin/ri \--slave /usr/bin/irb irb .

Join Stack Overflow to learn, share knowledge, and build your career. Connect and share knowledge within a single location that is structured and easy to search. Use the brightbox packages for 1. The new Ubuntu release has just rolled around and with it a slew of new packages. Personally, I'm tracking the ubbuntu of Ruby quite closely but the default Ruby on Ubuntu ist still the 1.

Ruby 1. However, as I have elaborated in a previous post getting the Ruby 1. Please read the post how to install ruby 1.9.3 on ubuntu you are interested in the details. The short version insfall You can get Ruby 1. The package is called 1. If you want to make this your exclusive Ruby and get rid of Ruby 1.

Edit: I found out today that there also is a package called ruby1. Aptitude confirms this:. Ruby packages in Debian are named using the Ruby library compatibility version, which is sometimes confusing for users who do not follow Ruby development closely.

This package depends on the ruby1. Yes, this will install Ruby 1. Stack Overflow for Teams — Collaborate and share knowledge with a private group. Create a free Team What is Teams? Learn more. How do I install Ruby 1. Ask Question. Asked 8 rubyy, 10 months ago. Active 3 years, 1 month ago. Viewed 27k times. I want to install ruby 1. And if I do sudo apt-get install ruby 1. How can I install ruby on Ubuntu? Improve this question.

Brian 11k 7 7 gold badges 32 32 silver badges 43 43 bronze badges. Download source code from ruby-lang. I don't see why it is hard unless you don't have linux experience at all — texasbruce Jun 18 '12 at I guess this is a valid way, but it also requires you to apply patches yourself and recompile from time to time.

RVM alleviates a lot of that pain and I guess the OP wants to be able to just run apt-get upgrade to get the newest fixes for his ruby version. It seems worth asking rhby you want to avoid RVM. I find what does fedex mean by in transit easy to unnecessarily limit ourselves because we've misunderstood something, and you can what to know about girls get the best help if you explain your actual goal.

Add a comment. Active Oldest Votes. On Ubuntu Improve this answer. This worked perfectly for me and is by far the easiest way to do it. E: Couldn't find any package by regex '1. If you want to make Ruby 1. There doesn't seem to be a rubygems1.

Compiling from Source is the standard way. Another method is apt package manager system. Shamith c Shamith c 3, 3 3 gold badges 22 22 silver badges 33 33 bronze badges. Sign up or log in Sign up using Google.

Sign up using Facebook. Sign up using Email and Password. Post as a guest Name. Email Required, but never instalo. The Overflow Blog. How to install ruby 1.9.3 on ubuntu on Meta.

New onboarding for review queues. Downvotes Survey results. Should questions about obfuscated code be off-topic? Linked 0. Related Hot Network Questions. Question feed. Stack Overflow works best with JavaScript enabled. Accept all cookies Customize settings.

How to Install Ruby 1.9.2 and Rails 3.0 on Ubuntu 10.10

sudo apt install libssldev curl -fsSL carolacosplay.us | rbenv install --patch p Found it in the link below. Installed libreadline5-dev package .deb in this case) downloaded manually, because the new ubuntu distro has only libreadline6-dev as candidate. went to rvm ruby src and: ruby carolacosplay.us --with-editline-dir=/usr/ --with-readline-dir=/usr/ make sudo make install. Now works like a . For installing in /opt: $./configure –prefix=/opt/ruby $ make install. If you want to use the /opt installed ruby, edit you ~/.bashrc and add. export PATH=/opt/ruby/bin/:$PATH. If you don't want to have the custom Ruby build as default, you can add this to your ~/.bashrc instead of the former command.

Join Stack Overflow to learn, share knowledge, and build your career. Connect and share knowledge within a single location that is structured and easy to search. I wonder about installing the latest version of Ruby on Ubuntu 9.

Now I can run through the. For example if some other package I install depends on Ruby, wouldn't the package manager install the outdated Ruby package and in the worst case overwrite my files? Keep in mind, Rails 3 works best with Ruby 1. Ruby 1. Currently the ruby1. The way I did it was to build it using checkinstall which lets you build a deb package. So I downloaded the Ruby 1. I got the Ruby specific info from this site. Here is a short and convenient way to install 1.

Looking through Synaptic it seems like you don't even have to deal with the Multiverse or third-party repositories. But since sudo apt-get install ruby currently installs an alias to ruby1. Anywhere on your PATH is fine, though. Stack Overflow for Teams — Collaborate and share knowledge with a private group.

Create a free Team What is Teams? Learn more. Installing Ruby 1. Ask Question. Asked 11 years, 9 months ago. Active 5 years, 11 months ago. Viewed 75k times. So I think I need some way to tell Ubuntu that Ruby is in fact already installed?

Improve this question. Caramiriel 5, 2 2 gold badges 25 25 silver badges 45 45 bronze badges. So, out of pure curiosity, is there any reason to have the absolute latest version of ruby?

I mean it's great to be bleeding edge, but is there actually any features that you need that this newest version has that the older versions don't? If there isn't, it seems a bit unnecessary to upgrade. I think so - it has unicode support, for one thing, is much faster, and supposedly has fixed some memory leaks of the older versions.

I am not a specialist on Ruby, though. However, I am developing on a Mac and I noticed that Ruby 1. Unicode really is the biggie for me, though. I heard that it works in Rails with Ruby 1. Also I don't have only Rails apps, also standalone Ruby. Why can't you just install it with apt? Add a comment. Active Oldest Votes. With RVM installing 1. Improve this answer. Daniil Shevelev Sam Saffron Sam Saffron k 74 74 gold badges silver badges bronze badges.

This page was particularly helpful: rubyinside. I should have checked into this sooner. Save your sanity, just install it from apt-get.

While it make work for some, I wasted half a day with it. Ubuntu Show 2 more comments. Ian Vaughan Ian Vaughan You might need to sudo apt-get remove ruby — Ian Vaughan Aug 25 '11 at I was installing ruby1. You also need to run sudo update-alternatives --config ruby to change the default to 1. No need to uninstall 1. As per my answer to this question. After running sudo apt-get install ruby1.

Thanks for this - I just blew half a day uninstalling, re-installing, compiling and recompiling from source, then using rvm, all the while wondering why 'ruby -v' doggedly kept returning 1. I don't know why this isn't at the least on the RVM install page. Works great on Tim Tim. Dykam Dykam 9, 4 4 gold badges 25 25 silver badges 32 32 bronze badges. Thanks, very helpful - at least that way I can avoid the conflicts.

Michael Lazarev Michael Lazarev 41 3 3 bronze badges. I created a launchpad ppa for ruby 1. I have added the ruby 1. Read more about it here humbug. Nikhil Chelliah Nikhil Chelliah 5, 1 1 gold badge 29 29 silver badges 30 30 bronze badges.

My impression was that in the repositories there is only Ruby 1. However, 1. You're right. Looks like you'll have to build it yourself for now. Sign up or log in Sign up using Google. Sign up using Facebook. Sign up using Email and Password. Post as a guest Name. Email Required, but never shown. The Overflow Blog. Featured on Meta. New onboarding for review queues.

Downvotes Survey results. Should questions about obfuscated code be off-topic? Linked Related Hot Network Questions. Question feed. Stack Overflow works best with JavaScript enabled. Accept all cookies Customize settings.





More articles in this category:
<- How to evangelize in the streets - How to remove my name from internet searches->


3 thoughts on “How to install ruby 1.9.3 on ubuntu”

Add a comment

Your email will not be published. Required fields are marked *